Turris Omnia and XS4ALL VDSL

Ronald van der Pol
Sun, Mar 15, 2020 - 384 Words - 2 minutes

Updated: 2020/03/22.

I am using an OpenWRT based Turris Omnia router with my ISP XS4ALL. Until recently, I used a simple VLAN setup, but that is not supported anymore. So I have moved to a routed setup.

Home network setup

Home network setup

The Turris Omnia does not have a VDSL interface. Therefore, I am using a DrayTek Vigor 130 modem in RFC 1483 bridge mode. On the Turris router I have two VLANs: VLAN ID 1 for my home network and VLAN ID 4 for the Arcadyan TV set top box. These are the relevant parts of /etc/config/network:

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option vid '1'
    option ports '0 1 2 3 5'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option vid '4'
    option ports '4 6'

config interface 'vdsl_ip'
    option proto 'pppoe'
    option ifname 'eth1.6'
    option username 'fb7360@xs4ll.nl'
    option password 'kpn'
    option ipv6 'auto'

config interface 'TV_WAN'
    option proto 'dhcp'
    option ifname 'eth1.4'
    option vendorid 'IPTV_STB_Arcadyan_HMB2260'
    option peerdns '0'

config interface 'TV_LAN'
    option proto 'static'
    option ifname 'eth2'
    option ipaddr '10.0.0.1'
    option netmask '255.255.255.0'
    option gateway '10.0.0.1'

config route
    option interface 'TV_WAN'
    option target '213.75.112.0'
    option netmask '255.255.248.0'
    option gateway '10.252.144.1'

The Turris router is runnung OS 3.x. In this version the internal switch is configured as follows:

Turris Omnia internal switch

Turris Omnia internal switch

The gateway towards the XS4ALL IPTV service is 10.252.144.1. I obtained this information by manually running udhcpc (with the “-V IPTV_STB_Arcadyan_HMB2260” option) and looking with tcpdump to what was returned. The reply also contained the network 213.75.112.0/21, which should by routed statically towards the gateway 10.252.144.1.

I also need to run an IGMP proxy. It configuration is:

config igmpproxy
    option quickleave 1

config phyint
    option network TV_WAN
    option direction upstream
    list altnet 217.166.0.0/16

config phyint
    option network TV_LAN
    option direction downstream

The 217.166.0.0/16 is used by the multicast streaming. I guessed the subnet mask because I could not find any information about it. Some on-demand services use unicast over the internet connection. In the firewall I allow this traffic.

Update 2020/03/22:

My IPTV stopped working. The stream froze every couple of seconds. Looking at the network traffic, I saw packets from a new IP range. After I added this static route, things were working again:

config route
        option interface 'TV_WAN'
        option target '213.75.167.0'
        option netmask '255.255.224.0'
        option gateway '10.252.144.1'